API Level

I just wanted to note that all of the Apps that I upload are set at an API level of 8. Basically that means that your Android Device must be running at least Android 2.2 (Frozen Yogurt) or later. If you are running Donut or Eclaire these Apps will not work and you should probably upgrade your phone. These should work fine on FroYo, Gingerbread, Honeycomb and Ice Cream Sandwich.

I don't know about you but this is making me hungry.